Воcпроизведение формата *.flac

TVIP S-BOX
Post Reply
majer
Posts: 2
Joined: 05 Aug 2014, 09:47

Воcпроизведение формата *.flac

Post by majer » 07 Apr 2022, 12:29

Добрый день, приставка модели s-530, должна ли воспроизводить аудио файлы формата FLAC ?
При попытке воспроизведения прогресс-бар не двигается, звук не воспроизводится.
В логах вижу следующее:

Code: Select all

" ====> URL: /tmp/mnt/sda1/1111/01._Adele_-_Daydreamer_(19).flac"
" .994 [STBPlayer:1762] Prepare OK. Starting decoders"
" ======> Stream #0, ID: 0 Audio: flac, 44100 Hz, stereo, s16 [44100 KHz, stereo], decoding s/w"
" .994 [STBPlayer:505] Setting player state from 'metaready' to 'preparing' (1ms)"
" .994 [STBPlayer:1759] Preparing '/tmp/mnt/sda1/1111/01._Adele_-_Daydreamer_(19).flac', video: 1, audio:0, subtitle:-2"
" ======> Stream #1, ID: 0 Video: mjpeg, yuvj420p(pc, bt470bg/unknown/unknown), 240x240 [SAR 1:1 DAR 1:1], decoding h/w"
" .994 [STBAmlPlatformPlayer:681] PlatformStartDecoders. stopping decoders"
" ============================================================================================================"
" ====> FORMAT: flac, START TIME: 00:00:00.000, DURATION: 00:03:40.507, SEEKABLE: yes"
" .995 [STBAmlDecoder:789] SetVideoParams: format:3, sysformat:0, sysparam: (nil), pid: 0"
" .996 [STBAmlDecoder:228] Intitializing codec 0xf44e8c8"
" [ 1640.847510@0] the vdec            clock on, ref cnt: 1"
" .996 [STBBitmapPngDecoder:168] Successfully decoded png: 39x30, filesize: 400"
" .995 [STBAmlDecoder:728] SetVideoParams: size: 240x240, rate:1, ratio:65537 ratio64:4294967297"
" .995 [STBAmlDecoder:1410] convertVideoCodecType: id=0x8 - setting default"
" [ 1640.847700@0] no drmmode"
" [ 1640.846761@0] audio_dsp: buf=0"
" .994 [STBAmlPlatformPlayer:744] Force: 1, needAudioChange: 1 needVideoChange: 1 needSubtitleChange: 1"
" .995 [STBAmlDecoder:1254] ConvertVideoCodec: video codec_id=0x8 format=3"
" [ 1640.847501@0] the parser_top      clock on, ref cnt: 1"
" [ 1640.846806@0] audio_dsp: IEC958_mode_raw=0"
" [ 1640.847488@0] the demux           clock on, ref cnt: 1"
" [ 1640.847536@0] the clk_vdec_mux    clock on, ref cnt: 1"
" [ 1640.847565@0] vdec mux clock is 500000000 Hz"
" [ 1640.847736@0] The fw has been loaded."
" [ 1640.847666@0] vdec_create instance ffffff800df60000, total 1"
" .001 [Image:116] Texture generated for bitmap: 30x30"
" .002 [Image:116] Texture generated for bitmap: 1621x60"
" [ 1640.850606@0] Video stbuf alloced at 0000000025c00000, secure = 0, size = 3145728"
" [ 1640.851330@0] decoder_bmmu_box_alloc_box, tvp_flags = 0"
" .001 [Image:116] Texture generated for bitmap: 1621x60"
" .001 [Image:116] Texture generated for bitmap: 1621x60"
" [ 1640.850694@0] vdec_init set vfm decoder ffffff800df60000"
" [ 1640.850656@0] vdec_init, dev_name:amvdec_mjpeg, vdec_type=VDEC_TYPE_SINGLE"
" [ 1640.851350@0] [LOCAL], the fw (mjpeg) will be loaded."
" .004 [Image:116] Texture generated for bitmap: 1621x60"
" .003 [Image:116] Texture generated for bitmap: 1621x60"
" .003 [Image:116] Texture generated for bitmap: 1621x60"
" .004 [Image:116] Texture generated for bitmap: 1621x60"
" .005 [Image:116] Texture generated for bitmap: 1621x60"
" .006 [Image:116] Texture generated for bitmap: 1621x60"
" .007 [Image:116] Texture generated for bitmap: 39x30"
" .008 [codec_ctrl:828] codec_init,untimed_text=1"
" .009 [STBAmlPlatformPlayer:950] Video decoder started"
" .008 [codec_ctrl:1174] video_pause!"
" .008 [codec_ctrl:1206] [codec_pause]p->has_audio=0"
" .009 [STBAmlDecoder:826] Audio extended info: fmt=1 srate=44100 chanels=2 extrasize=0"
" [ 1640.858124@0] vdec_request_irq ffffff8001e83b58, parser"
" .008 [STBAmlDecoder:103] Updating volume settings"
" [ 1640.856643@0] DI: di_receiver_event_fun: vframe provider reg decoder.mjpeg"
" .009 [STBAmlDecoder:843] SetAudioParams: audio type: 1, pid: 0"
" .008 [STBAmlDecoder:283] Codec 0xf44e8c8 initialized"
" [ 1640.858059@0] video first pts = 0"
" [ 1640.856584@0] vdec_request_irq ffffff8001f9d7e8, vmjpeg-irq"
" [ 1640.856893@0] vdec_init, vf_provider_name = "
" .012 [codec_ctrl:204] set_audio_info"
" .011 [STBAmlDecoder:228] Intitializing codec 0xf44fb20"
" [ 1640.862769@0] the demux           clock on, ref cnt: 2"
" [ 1640.862786@0] the parser_top      clock on, ref cnt: 2"
" [ 1640.863657@0] The fw has been loaded."
" .016 [adec-internal-mgt:759] audiodec_init!"
" [ 1640.868142@0] vdec1 video changed to 240 x 240 96000 fps clk->667MHZ"
" [ 1640.868130@0] vdec mux clock is 666666666 Hz"
" .017 [adec-internal-mgt:668] media.armdecode.audiocodec = ape,flac,wma,wmapro,aac,vorbis,raac,cook,amr,pcm,adpcm,aac_latm,rm,opus, t->type = pcm"
" [ 1640.865143@0] audio first pts = 0"
" [ 1640.864403@0] Audio stbuf alloced at 0000000026d00000, secure = 0, size = 1572864"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:2]--not~fit-[audio_lib_list[i].name:libtvip_faad.so]"
" .018 [adec-ffmpeg-mgt:88] Open library: libtvip_pcm.so"
" .017 [adec-ffmpeg-mgt:76] [find_audio_lib 76]audec->format/1 audec->codec_id/0x10000"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:27]--not~fit-[audio_lib_list[i].name:libtvip_mad.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:7]--not~fit-[audio_lib_list[i].name:libtvip_pcm.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:26]--not~fit-[audio_lib_list[i].name:libtvip_mad.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:9]--not~fit-[audio_lib_list[i].name:libtvip_cook.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:12]--not~fit-[audio_lib_list[i].name:libtvip_amr.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:8]--not~fit-[audio_lib_list[i].name:libtvip_flac.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:0]--not~fit-[audio_lib_list[i].name:libtvip_mad.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:20]--not~fit-[audio_lib_list[i].name:libtvip_ape.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:13]--not~fit-[audio_lib_list[i].name:libtvip_raac.so]"
" .017 [adec-ffmpeg-mgt:111] [find_audio_lib::111]--[f->codec_id:19]--not~fit-[audio_lib_list[i].name:libtvip_faad.so]"
" .019 [adec_read:78] memmap = f1401000 , pagesize = 1000"
" .019 [adec_read:73] add=c1105000, size=00001000, offset=00000000"
" .021 [adec-ffmpeg-mgt:1481] wait audio sr/channel done "
" .019 [STBAmlDecoder:67] Setting sync mode to enabled"
" .019 [adec-ffmpeg-mgt:482] [OutBufferInit 482]pcm buffer init ok buf_size:1920000"
" .020 [FFmpegAudioTranscoder:28] Opening flac decoder"
" .018 [adec-ffmpeg-mgt:595] [audio_codec_init 595]param:data_width:0 samplerate:44100 channel:2 "
" .019 [STBPlayer:1765] Decoders started"
" .021 [adec-ffmpeg-mgt:986] [start_decode_thread]Create ffmpeg decode thread success! tid = -487590832"
" .020 [STBPlayer:505] Setting player state from 'preparing' to 'playing' (26ms)"
" .020 [FFmpegAudioTranscoder:55] Successfully created decoder from flac (tb:1/44100)"
" .021 [STBAmlDisplay:878] Device resolution: 1920x1080"
" .019 [STBAmlDecoder:103] Updating volume settings"
" .021 [adec-ffmpeg-mgt:1235] adec_armdec_loop start!"
" .021 [STBAmlDisplay:883] Converted position: 0,0,0,0, clip: 0,0,0,0"
" .019 [STBAmlDecoder:67] Setting sync mode to disabled"
" [ 1640.869813@2]  "
" .019 [STBAmlDecoder:283] Codec 0xf44fb20 initialized"
" .020 [adec-ffmpeg-mgt:1130] [audio_getpackage_loop]adec_getpackage_loop start! Buffer: 256"
" .019 [STBAmlPlatformPlayer:968] Audio decoder started"
" .019 [adec-ffmpeg-mgt:631] [audio_codec_init 631]param_applied: bps:16 samplerate:44100 channel:2 "
" .019 [codec_ctrl:828] codec_init,untimed_text=1"
" .020 [adec-ffmpeg-mgt:976] [start_decode_thread]Create get package thread success! tid = -495979440"
" .020 [FFmpegAudioTranscoder:34] Using legacy api"
" .019 [adec-ffmpeg-mgt:469] [OutBufferInit 469] audec->g_bst/0xed802a08"
" .019 [codec_ctrl:1206] [codec_pause]p->has_audio=1"
" .018 [adec-internal-mgt:801] Create adec main thread success! tid = -504368048"
" [ 1640.869813@2] audio_dsp: codec_fatal_err value:0"
" [ 1640.870581@2] [store_mode]tsync_mode=1, buf=1"
" .021 [adec-ffmpeg-mgt:1477] wait audio sr/channel begin "
" .023 [STBPlayer:810] dataThread: started"
" .025 [FFmpegAudioTranscoder:351] First frame was successfully decoded. Sample rate: 44100, channel layout:stereo"
" [ 1640.874466@1] hdmitx: fs = 2, cd = 4, tmds_clk = 148500"
" [ 1640.874488@1] hdmitx: hw: aud_n_para = 6272"
" [ 1640.874529@1] hdmitx: hw: set channel status"
" .025 [adec-ffmpeg-mgt:789] wait first apts count :100 "
" .027 [FFmpegAudioTranscoder:142] Opening encoder pcm_s16le"
" .025 [STBPlayer:874] ptsThread: started. Current from UNKNOWN"
" [ 1640.874359@1] hdmitx: hw: set audio"
" .023 [STBPlayer:774] Creating data thread"
" .024 [alsa-out:1218] Create alsa playback loop thread success ! tid = -443968432"
" [ 1640.874600@1] hdmitx: audio: Audio Type: PCM"
" .023 [STBPlayer:781] Creating PTS thread"
" [ 1640.874409@1] hdmitx: hw: hdmitx tx_aud_src = 0"
" .025 [adec-ffmpeg-mgt:795] wait first pts checkin complete !"
" .021 [alsa-out:1080] alsa out init"
" [ 1640.874621@1] hdmitx: audio: set audio param"
" .026 [alsa-out:689] yvonnepthread_cond_wait"
" .028 [FFmpegAudioTranscoder:167] Successfully opened encoder pcm_s16le"
" .028 [FFmpegAudioTranscoder:176] Opening filters"
" .029 [FFmpegAudioTranscoder:190] sourceArgsStream: time_base=1/44100:sample_rate=44100:sample_fmt=s16:channel_layout=0x3"
" .033 [FFMPEG:50] [source @ 0xf2605b70] tb:1/44100 samplefmt:s16 samplerate:44100 chlayout:0x3"
" .034 [FFmpegAudioTranscoder:287] Successfully created filters"
" .034 [FFMPEG:50] [Parsed_aresample_0 @ 0xf2605f40] ch:2 chl:stereo fmt:s16 r:44100Hz -> ch:2 chl:stereo fmt:s16 r:44100Hz"
" .034 [FFmpegAudioTranscoder:229] Encoder frame size 0 samples"
" [ 1640.886527@3] audio first checkin pts =0"
" [ 1640.886565@3] first check in apts <0x0:0x0> ok!"
" .095 [UISystem:392] Event processing: "Key: enter" ..."
" .125 [adec-ffmpeg-mgt:822] get first apts ok, times:1 need_stop:0 auto_mute 0"
" .126 [adec-pts-mgt:107] adec_pts_start"
" .126 [adec-pts-mgt:120] av sync threshold is 5400 , no_first_apts=0,"
" .126 [adec-pts-mgt:117] use default av sync threshold!"
" .128 [adec-pts-mgt:170] audio pts start from 0x1"
" [ 1640.980559@2] timestamp_apts_enable enable:1,"
" .129 [alsa-out:1249] yvonne pthread_cond_signalalsa_param->wait_flag=1"
" [ 1640.980649@2] audio pts started::::::: 1"
" .130 [adec-ffmpeg-mgt:1524] Receive PAUSE Command!"
" [ 1640.979421@2] audio first pts = 1"
" [ 1640.977935@2] audio pts started::::::: 0"
" .129 [alsa-out:1235] alsa out start!"
" [ 1640.981639@2] timestamp_apts_enable enable:0,"
" .130 [alsa-out:1264] alsa out pause"
" .130 [adec-ffmpeg-mgt:1550] Receive Set Vol Command!"
" .130 [adec-pts-mgt:388] adec_pts_pause"
" .130 [alsa-out:701] alsa playback loop start to run !"
" .134 [adec-ffmpeg-mgt:1542] Receive Mute Command!"
" .133 [adec-ffmpeg-mgt:932] set audio volume! vol = 0.840000"
" .134 [adec-ffmpeg-mgt:917] unmute the output !"
" .251 [UISystem:392] Event processing: "KeyUp: enter" ..."
" [ 1643.630722@2] unifykey: amlkey_size() 340: ret 1"
" [ 1647.637441@1] meson-remote c8100580.rc: invalid custom:0xfd02fb04"
" [ 1647.637522@1] meson-remote c8100580.rc: cur_custom is nulll"
" [ 1647.637545@1] meson-remote c8100580.rc: no valid key to handle"
" [ 1649.628976@1] meson-remote c8100580.rc: invalid custom:0xfc03fb04"
" [ 1649.629046@1] meson-remote c8100580.rc: no valid key to handle"
" [ 1649.629026@1] meson-remote c8100580.rc: cur_custom is nulll"
" [ 1652.658945@1] meson-remote c8100580.rc: invalid custom:0xfc03fb04"
" [ 1652.659023@1] meson-remote c8100580.rc: cur_custom is nulll"
" [ 1652.659046@1] meson-remote c8100580.rc: no valid key to handle"
" .334 [STBAmlDecoder:388] Decoder seems stuck. Try to reset PCR"
" [ 1653.631478@2] unifykey: amlkey_size() 340: ret 1"
" [ 1653.877395@1] meson-remote c8100580.rc: invalid custom:0xfd02fb04"
" [ 1653.877497@1] meson-remote c8100580.rc: no valid key to handle"
" [ 1653.877475@1] meson-remote c8100580.rc: cur_custom is nulll"
" [ 1654.577394@1] meson-remote c8100580.rc: invalid custom:0xfc03fb04"
" [ 1654.577484@1] meson-remote c8100580.rc: cur_custom is nulll"
" [ 1654.577509@1] meson-remote c8100580.rc: no valid key to handle"
" .307 [BaseSettingsManager:218] Delayed setting write."
" .192 [UISystem:392] Event processing: "KeyDown: enter" ..."
" .193 [Widget:1069] Widget got focus: 0xf771360"
" .193 [UISystem:392] Event processing: "Key: enter" ..."
" .196 [RemoteV2Logic:38] RC revision detected 1"
" .312 [UISystem:392] Event processing: "Key: enter" ..."
" .465 [UISystem:392] Event processing: "KeyUp: enter" ..."
" .978 [UISystem:392] Event processing: "KeyDown: enter" ..."
" .979 [UISystem:392] Event processing: "Key: enter" ..."
" .979 [Widget:460] SetActiveChild. Widget "mediaplayer_playback" is not visible"
" .980 [RemoteV2Logic:38] RC revision detected 1"
" .098 [UISystem:392] Event processing: "Key: enter" ..."
" .253 [UISystem:392] Event processing: "KeyUp: enter" ..."
" [ 1663.632272@2] unifykey: amlkey_size() 340: ret 1"
" .690 [STBAmlDecoder:388] Decoder seems stuck. Try to reset PCR"

ftor
Posts: 805
Joined: 12 May 2020, 09:22

Re: Воcпроизведение формата *.flac

Post by ftor » 07 Apr 2022, 15:33

Добрый день,

Уточните версию firmware

majer
Posts: 2
Joined: 05 Aug 2014, 09:47

Re: Воcпроизведение формата *.flac

Post by majer » 08 Apr 2022, 15:15

ftor wrote:
07 Apr 2022, 15:33
Добрый день,

Уточните версию firmware
5.0.48

ftor
Posts: 805
Joined: 12 May 2020, 09:22

Re: Воcпроизведение формата *.flac

Post by ftor » 08 Apr 2022, 15:42

Поделитесь образцом семпла с которым есть проблема

Post Reply